Domů

NÁVOD: Downgrade z iOS 6.1.3 na 6.1.2

Downgrade1[1]

Na přání našeho čtenáře píšu tento návod, určitě ale přijde vhod i ostatním. Důvod tohoto kroku je prostý – iOS 6.1.2 je poslední podporovaný firmware pro jailbreak Evasi0n. Takže co budete potřebovat?

  • iPhone 4 nebo iPhone 3Gs
  • iPod Touch 4

Zde narážíme na jeden, zato zásadní problém – je to proveditelné pouze na modelech s A4 procesorem, takže ti, co mají iPhone 4S nebo novější mají bohužel smůlu, pokud se však objeví možnost downgradu i pro tyto zařízení, ihned Vás o tom budeme informovat.

Takže pokud jste splnili první krok, pokračujeme dále.

Před pokračováním doporučuji zazálohovat Vaše zařízení! Za ztracená data neručíme.

1. První krok, ke kterému budeme potřebovat právě program TinyUmbrella

  • Připojte zařízení k počítači
  • Spusťte stažený program TinyUmbrella
  • Vyberte Vaše zařízení z levého sloupečku
  • Klikněte na tlačítko „Save SHSH“ (viz obrázek)

TinyUmbrella-home[1]

 

  • Nyní si vyberete umístění, kam chcete SHSH uložit (někam, kde je poté najdete… :-) )

2. Teď přichází na řadu druhý krok, ve kterém budeme potřebovat další program, který se jmenuje Sn0wbreeze

  • Sáhněte si sn0wbreeze ZDE (pouze windows)
  • Po spuštění aplikace se objeví okno s upozorněním od autora – klikněte na OK
  • Následně dejte modrou šipku a poté klikněte na Browse for an IPSW, kde vyberete stažený firmware

snow1wm

snow2wm

 

  • Nyní vyberte bootrom a poté opět klikněte na modrou šipku
  • Následně vyberte iFaith Mode, ve kterém poté vyberte uložené SHSH (provedeno v 1. kroku)
  • Nyní se začne vytvářet nový IPSW soubor

3. Nyní bude potřeba připravit zařízení na resotre

  • Pro vložení právě vytvořeného IPSW souboru je zapotřebí vložit telefon do DFU módu
    • Nechte zařízení připojený k PC
    • Vypněte iPhone/iPod
    • Po vypnutí:
      • Držte horní tlačítko, dokud se neukáže jablko
      • Ihned po zobrazení Apple loga stiskněte společně s horním (zapínacím) tlačítkem i home tlačítko a držte
      • Po chvilce vy měl probliknout display, POŘÁD DRŽTE OBĚ DVĚ TLAČÍTKA, dokud se opět neobjeví logo
      • Po obětovném načtení jablka pusťte horní tlačítko a držte pouze home tlačítko
    • Pokud jste udělali všechno správně, tak by se na zařízení měl objevil znak iTunes a pod ním USB kabel a v iTunes v PC by se mělo zařízení po chvilce zobrazit
  • V itunes budete mít vedle zařízení také tlačítko Restore
  • Stiskněte Shift(Widnows) nebo alt(Mac) a držte a k tomu stiskněte Restore v iTunes
  • Budete vyzváni k vybrání .ipsw souboru
  • Na ploše byste měli mít tento soubor vytvořený (2. krok)
  • Vyberte tento soubor

Poté začne obnova zařízení a pokud jste udělali vše správně a nikde nenastala žádná chyba, měli byste po chvilce mít ve vašem zařízení požadovaný firmware.

Pokud budete mít nějaké problémy, nebo naopak úspěchy, určitě se o ně podělte s ostatními v komentářích pod příspěvkem. :-)



Source : iPho9

O autorovi

Štěpán Němejc

Zakladatel, spolumajitel a developer iPhonista.cz

21 Komentářů

  • Cau piše mi tam chybu v snowbreeze ked dam ifaith mod a vyberem ios 6.0.1 alebo 6.1.2 tak mi ukaze chybu Invalid blobs/device +ios combination

  • Ahoj, mám takový menší problém. Vlastním IP5 s tím , že má poslední aktualní verzi sw 6.1.3 a chtěl bych provést downgrade přes iTunes na verzi 6.1.2.. Ale stále mi to píše chybu 3194..

    Jak provést JB pro tento MT?

    Děkuji za tvou odpověď

    RB

  • Ahoj,
    Mám iPhone 3GS 32GB a chtěl jsem udělat ten downgrade ,ale mám takový problém:(Popisuješ to strašně asi strašně stručně a mi to ani za nic nechce udělat v tom umbrella ten SHSH soubor ,který mám pak vložit asi do toho sn0wbreeze.Nevíš co mám dělat ? nejde to někde stáhnout ?

    • Ahoj, SHSH soubor lze vytvořit pouze v momentě, pokud máš SHSH bloky uložené. To se provádí automaticky při zapnutí cydie na telefonu (poté se uloží SHSH pro příslušný fw). Stáhnout nejdou, obsahují unikátní informace pro každé zařízení.

  • Ahoj,
    Při vytváření nového IPSW souboru mi to hodí následující chybu: The provided apticket does not look valid, sn0wbreeze will refuse to build an IPSW with this apticket as it may put your device in an inusable state.
    Mohl by jsi mi prosím poradit, jak se přes to dostat?
    Děkuji za odpověď

  • Ahoj,
    lze pomocí tohoto postupu udělat upgrade (z firmware 5.1 na 6.1.2)? Nebo musím napřed přejít na 6.1.3 a pak teprv mohu udělat tento downgrade?
    Díky!

  • Ahoj, jak již tady někdo psal, ve Snowbreeze mi to hází chybu Invalid blobs/device +ios combination. Jinde na netu jsem se dočetl, že pro downgrade potřebuju mít SHSH soubory vytvořené ve verzi, na kterou chci provést downgrade. Ty ale nemám. Je to skutečná příčina této chyby? Mám prostě smůlu, nebo je jiná možnost provést downgrade a především nainstalovat Jailbreak?

    • Vypadá to, že jsem to špatně napsal, ale v principu ty SHSH blobs jsou unikátní soubory, které uchovávají možnost downgradovat na firmware, ve kterém byly vytvořeny – je to taková záloha, takže je musíte vytvořit pro verzi, na kterou chcete downgradovat a to znamená, že musíte myslet dopředu a vytvořit je pro jistotu „kdyby někdy náhodou“, takže bohužel, v tuto chvíli to asi pro Vás bude problém… :-(

      • Ahoj Štěpáne,
        dokážeš mi poradit, jak mohu na svém iPadu 6.1.3. provést jailbreak? Měl jsem 6.1.2. a jailbreak od cydia. Jednoho krásnýho dne jsem se připojil k iTunes a svojí blbostí jsem nechal aktualizovat na 6.1.3. a neuvědomil jsem si, co příjde potom. Samozřejmě, že upgrade a totální výmaz všecho, co jsem potřeboval k práci. Jsem teď totálně nahranej a potřeboval bych vážně poradit. Můžeš mi prosím napsat do mailu, jestli dokážu dostat JB do novýho iOS?
        Mockrát děkuji za odpověď. Když bude nějaká cesta fungovat, tak zaručuji odměnu.
        Ladislav (iPad 3rd generation, 16 GB, Retina display)

        • V současné době je sice pravda, že downgrade neuděláte, dobrou zprávou je však to, že týmu evasi0n se povedlo najít možnost, jak udělat jailbreak i na iOS 6.1.3 a nyní prý budou jen nějaký čas testovat a poté jailbreak vydají. Jak se tak stane, budeme Vás neprodleně informovat :-)

          Štěpán Němejc

  • Chci provést downgrade z iOS 6.1.3 na 6.1.2 s použitím TinyUmbrella u iPhone 4 GSM ( A1332 ) avšak po spuštění snowbreeze a browse for an IPSW mi u všech stažených firmware pro iPhone 4 GSM hlásí invalid IPSW. Mám iPhone 4 model A 1332 tedy GSM iPhone 3,1. V čem může být chyba?

  • Snowbreeze mi již detekuje potřebný firmware, avšak v dalším kroku po zadání SHSH opakovaně píše Invalid blobs/Device + iOS Combination a neumožňuje vytvořit nový soubor IPSW . Ani opakované uložení SHSH použitím TinyUmbrella nevede k cíli. prosím o radu.

  • Dobrý, chtěl bych se zeptat jestli je možnost jak provést downgrade bez SHSH, (jak ho ziskat, když mi TinyUmbrella zazálohovala pouze 4.1. a 6.1.3)
    Díky

Zanechte komentář